Skip to Main Content
IBM Data Platform Ideas Portal for Customers


This portal is to open public enhancement requests against products and services offered by the IBM Data Platform organization. To view all of your ideas submitted to IBM, create and manage groups of Ideas, or create an idea explicitly set to be either visible by all (public) or visible only to you and IBM (private), use the IBM Unified Ideas Portal (https://ideas.ibm.com).


Shape the future of IBM!

We invite you to shape the future of IBM, including product roadmaps, by submitting ideas that matter to you the most. Here's how it works:


Search existing ideas

Start by searching and reviewing ideas and requests to enhance a product or service. Take a look at ideas others have posted, and add a comment, vote, or subscribe to updates on them if they matter to you. If you can't find what you are looking for,


Post your ideas

Post ideas and requests to enhance a product or service. Take a look at ideas others have posted and upvote them if they matter to you,

  1. Post an idea

  2. Upvote ideas that matter most to you

  3. Get feedback from the IBM team to refine your idea


Specific links you will want to bookmark for future use

Welcome to the IBM Ideas Portal (https://www.ibm.com/ideas) - Use this site to find out additional information and details about the IBM Ideas process and statuses.

IBM Unified Ideas Portal (https://ideas.ibm.com) - Use this site to view all of your ideas, create new ideas for any IBM product, or search for ideas across all of IBM.

ideasibm@us.ibm.com - Use this email to suggest enhancements to the Ideas process or request help from IBM for submitting your Ideas.

IBM Employees should enter Ideas at https://ideas.ibm.com



ADD A NEW IDEA

Clear

Ideas

Include rotatelogs binary by default in base image

The file generated by the engine at /tmp/engine-*.out grows unbound. The engine scripts (libexec/_sdc) do contain logic to utilize the rotatelogs command if available, however this is not the default. The log file /tmp/engine-*.out growing unbound...
about 2 months ago in StreamSets 0 Submitted

Connect to SAP Datasphere as a datasource for connection and for IKC.

SAP Datasphere is a new data warehouse from SAP competing with Snowflake, Google Bigquery, Azure Redshift, Db2 and other data catalog solutions for SAP data. Clients who are deploying SAP would use Datasphere for connecting, managing, cataloging a...
over 1 year ago in Connectivity 1 Under review

DVM JDBC Gateway official documentation missing

The official DVM documentation does not provide the necessary steps to configure the DataSource connection configuration on JDBC Gateway using SSL and Kerberos on z/OS LPAR. https://www.ibm.com/docs/en/dvm/1.1.0?topic=ssl-enabling-support https://...
over 2 years ago in Data Virtualization Manager for z/OS 1 Not under consideration

Oracle DataStage Connector Should Automatically Serialize XMLTYPE Columns to LONGVARBINARY Instead of Requiring Explicit getBlobVal() in Every Query

I have an oracle table with a column of type XMLTYPE. I have a flow where, using oracle-datastage conenctor, I try to cast this xml data into LONGVARBINARY type to be used in the flow. They are receiving the following error when trying to run that...
2 months ago in Connectivity 0 Submitted

Enable JDBC Producer to generate SQL Server-compatible DELETE statements when Multi-Row Operation is enabled for tables with multi-column primary keys.

== Problem: JDBC Producer generates DELETE statements incompatible with Microsoft SQL Server when "Use Multi-Row Operation" is enabled for tables with multi-column primary keys. == Current Behavior: JDBC Producer generates: DELETE FROM table WHERE...
2 months ago in StreamSets 1 Under review

DataDirect jdbc driver for mongodb support balanced string

Then this idea stems from the fact that the customer wanted to connect to mongodb through our jdbc driver, however their mongodb team provided him with a balanced string with a replicaset parameter that allows you to replicate data on the affected...
over 6 years ago in Connectivity 1 Not under consideration

Notification of a Failed Job Run from a Scheduled Task

Would like to be able to receive a notification when a Scheduled Task fails to start a job. Jobs stuck in a job status that is not inactive will fail to start and would like either an option to be notified of a failure when configuring the Schedul...
over 1 year ago in StreamSets 2 Under review

Add headers errorStackTrace, error JobId and errorJobName to Oracle CDC evicted transaction error record.

This would allow the user to identify the job that generated the error record. Currently, all three headers are null when there viewing the error record from an Oracle CDC evicted transaction. "errorStackTrace":null, "errorJobId":null, "errorJobNa...
10 months ago in StreamSets 0 Submitted

Oracle stored procedure support with DRDA-passthrough

We need to have support for Oracle Stored procedure and sequence using DRDA-passthrough. At the moment we have programs running on z/Os that are using Oracle client that is out of support and will no longer be working with the latest Oracle releas...
about 3 years ago in Data Virtualization Manager for z/OS 1 Not under consideration

Oracle NetSuite connector

Customers have a growing amount of ERP and ERP vendors do not like applications to connect to the back end data source. Customer is requesting for the ability to connect to Oracle NetSuite through API or other means. Once the connector is availabl...
11 months ago in Connectivity 0 Needs more information