Skip to Main Content
IBM Data Platform Ideas Portal for Customers


This portal is to open public enhancement requests against products and services offered by the IBM Data Platform organization. To view all of your ideas submitted to IBM, create and manage groups of Ideas, or create an idea explicitly set to be either visible by all (public) or visible only to you and IBM (private), use the IBM Unified Ideas Portal (https://ideas.ibm.com).


Shape the future of IBM!

We invite you to shape the future of IBM, including product roadmaps, by submitting ideas that matter to you the most. Here's how it works:


Search existing ideas

Start by searching and reviewing ideas and requests to enhance a product or service. Take a look at ideas others have posted, and add a comment, vote, or subscribe to updates on them if they matter to you. If you can't find what you are looking for,


Post your ideas

Post ideas and requests to enhance a product or service. Take a look at ideas others have posted and upvote them if they matter to you,

  1. Post an idea

  2. Upvote ideas that matter most to you

  3. Get feedback from the IBM team to refine your idea


Specific links you will want to bookmark for future use

Welcome to the IBM Ideas Portal (https://www.ibm.com/ideas) - Use this site to find out additional information and details about the IBM Ideas process and statuses.

IBM Unified Ideas Portal (https://ideas.ibm.com) - Use this site to view all of your ideas, create new ideas for any IBM product, or search for ideas across all of IBM.

ideasibm@us.ibm.com - Use this email to suggest enhancements to the Ideas process or request help from IBM for submitting your Ideas.

IBM Employees should enter Ideas at https://ideas.ibm.com



ADD A NEW IDEA

Clear

Ideas

Generic Error Message for Failed Authenticaion

Hi, I would like to know if you could change the error message comes from DB2 for z/OS via IBM Client Driver when a wrong user name or password is given. In this current situation we get two types of error messages one states that USER DISABLED/R...
about 5 years ago in Db2 for z/OS 1 Functionality already exists

Repair Catalog of Indexspaces

After using DSN1COPY to copy table- and indexspaces from one subsystem to another it is possible to do a REPAIR CATALOG to update catalog informations about RBA format, Row format and versions. There is no possiblity to repair index RBA format. We...
over 10 years ago in Db2 for z/OS 1 Not under consideration

Row Change Timesatmp with Precision 12 and Timezone

Row change timestamp is sensitive to changing from daylight savings time to standard time since it doesn't support TIMESTAMP WITH TIMEZONE and other precisions than 6.Applications have two requirements that could be combined and solved by the row ...
almost 13 years ago in Db2 for z/OS 1 Not under consideration

flood of console with I/O error messages when Db2 is always tring to allocate/open LOGCOPY1 first for each LOG-READ request

Customer would like to avoid a flood of console with I/O error messages. The test environment and scenario is as follows.environment: - DB2 V11 DATA sharing (We have three MEMBER DB1A, DB2A, DB3A) - Q-Capture(IIDR for DB2 V10.2.1) server is runnin...
almost 8 years ago in Db2 for z/OS 0 Not under consideration

Current authorization session variable

We would like to have a session variable that would identify the current authorization in use by a connection. By "current authorization", I would like it to identify the package owner of the package being executed for static sql or dynamic sql us...
almost 8 years ago in Db2 for z/OS 1 Not under consideration

in DB2 v.11 env. question on use of httpgetblobfile

Problem description and business impact customer in z/os v2.2 and db2 v.11 have a question on function httpgetblobfile: the function (db2xml.httpgetblobfile but also db2xml.httpgetclobfile) has in input a varchar with the url and a clob with the h...
almost 8 years ago in Db2 for z/OS 1 Not under consideration

Avoid writing to intermed...

Avoid writing to intermediate workfile for inner table expressions with ROWNUMBER() In SAP lifecycle management tasks, standard SAP tables need to be split in buckets of about the same size via primary key. The idea is then to process these bucket...
almost 8 years ago in Db2 for z/OS 1 Not under consideration

Backout also if system errors occours using 'load resume yes backout yes'

Load resume yes backout yes should perform the backout process also when some system error occurs (ie.: space constraints on utility datasets), primarily in case of DISCARDS 1 specification.With this choice the customer wish to prefer the preserva...
almost 8 years ago in Db2 for z/OS 1 Not under consideration

Allow a Db2 z/OS Server to request clients set other JDBC Data Server Driver parameters, such as minTransportObjects or maxTransportObjects

In FL502 of Db2 13, IBM offers MODIFY DDF with the "RQSTWLB" option which allows the Db2 server to tell clients to enable Sysplex Workload Balancing (enableSysplexWLB=true) as long as the client doesn't explicitly set WLB to "false". It would be b...
over 2 years ago in Db2 for z/OS 2 Future consideration

Db2: Recovery of Mainframe Db2 databases without applying changes.

When the DB2 is performing a recover it uses log and copy files, it may be some sitations where the log contains changes that we dont want to restore. For exemple we may have inserts made by an authorized program and also updates performed by an u...
over 2 years ago in Db2 for z/OS 1 Not under consideration