Skip to Main Content
IBM Data Platform Ideas Portal for Customers


This portal is to open public enhancement requests against products and services offered by the IBM Data Platform organization. To view all of your ideas submitted to IBM, create and manage groups of Ideas, or create an idea explicitly set to be either visible by all (public) or visible only to you and IBM (private), use the IBM Unified Ideas Portal (https://ideas.ibm.com).


Shape the future of IBM!

We invite you to shape the future of IBM, including product roadmaps, by submitting ideas that matter to you the most. Here's how it works:


Search existing ideas

Start by searching and reviewing ideas and requests to enhance a product or service. Take a look at ideas others have posted, and add a comment, vote, or subscribe to updates on them if they matter to you. If you can't find what you are looking for,


Post your ideas

Post ideas and requests to enhance a product or service. Take a look at ideas others have posted and upvote them if they matter to you,

  1. Post an idea

  2. Upvote ideas that matter most to you

  3. Get feedback from the IBM team to refine your idea


Specific links you will want to bookmark for future use

Welcome to the IBM Ideas Portal (https://www.ibm.com/ideas) - Use this site to find out additional information and details about the IBM Ideas process and statuses.

IBM Unified Ideas Portal (https://ideas.ibm.com) - Use this site to view all of your ideas, create new ideas for any IBM product, or search for ideas across all of IBM.

ideasibm@us.ibm.com - Use this email to suggest enhancements to the Ideas process or request help from IBM for submitting your Ideas.

IBM Employees should enter Ideas at https://ideas.ibm.com



ADD A NEW IDEA

Clear

Ideas

DB2 for z/OS ALTER FUNCTION REPLACE for inline SQL scalar and SQL table functions

Create an ALTER FUNCTION REPLACE statement for inline SQL scalar and SQL table functions such as already exists for compiled SQL functions and native SQL procedures. This would give the ability of the user to modify the source code for these funct...
over 11 years ago in Db2 for z/OS 0 Not under consideration

Expand RETPD in template to 5 digits

RETPD parm in the template should allow 5 digits with a value up to 93000
over 8 years ago in Db2 for z/OS 0 Not under consideration

Request for a new zParm parameter, named for example IXCOPY to be set to YES or NO in order to choose how DB2 creates IX

This RFE requests a new zParm parameter, named for example IXCOPY to be set to YES or NO in order to choose the default for indexes creation:- if IXCOPY = NO (default) DB2 will continue to work as now, that means that DB2 will create all indexes C...
over 11 years ago in Db2 for z/OS 1 Future consideration

Query Nodes - Allow Certain Members of a DB2 Group to Process Queries Against OLTP Data Without Interfering with OLTP

In a DB2 for z/OS data-sharing group, allow customers to designate certain DB2 members as "query-only" subsystems. A "query-only" subsystem, or "query node" would process queries for analytics and business intelligence against the same databases a...
almost 9 years ago in Db2 for z/OS 1 Not under consideration

Avoid Db2 failure even if it got BSDS access initialization failure (BSDS timestamp mismatch)

[Background]- Customer's GRSRNL specifies SYSVSAM in systems exclusion list because they need to share CATALOGs. [Description]Our customer got BSDS Access initialization failure and starting Db2 was failed. Please refer to PMR#55237,615,760.They c...
almost 9 years ago in Db2 for z/OS 0 Functionality already exists

Prohibit inoperative packages after drop function

DROP and CREATE of userdefined function KZZ.LEXSORT set packages KIS##01 and KIS##30 to inoperative. Error in IMS region BOKMSG8F: SQLCODE = -904, ERROR: UNSUCCESSFUL EXECUTION CAUSED BY AN UNAVAILABLE RESOURCE. REASON 00E30305, TYPE OF RESOURCE 0...
over 11 years ago in Db2 for z/OS 0 Not under consideration

Monitor thread causing DB2 abend

Hi Team, We had a Db2 system abend for production environment because of QUERY ON BLOCKING_THREADS has cancelled . We had a business impact for this. If we can monitor such thread proactively before it get cancel, then it may save us from DB2 aben...
almost 3 years ago in Db2 for z/OS 1 Functionality already exists

Add flag field to IFCID 402 to indicate when a reset has occurred.

In Db2 Version 13 and V12 (with APAR PH50729), Db2 resets IFCID 402 statistic counters immediately if the warning or exception threshold for the associated profiles is changed when you issue a START PROFILE command. It’s difficult to tell if the c...
almost 3 years ago in Db2 for z/OS 1 Not under consideration

Add SET CURRENT QUERY ACCELERATION WAITFORDATA setting into Profile Table in Db2 for z/OS

When Waitfordata setting is required for HTAP queries in IDAA for dynamic SQLs, waitfordata should be defined either in zPARM or as a register setting in application before the SQL statement which requires application change. It would be better to...
almost 3 years ago in Db2 for z/OS 2 Functionality already exists

Long Time to restart DB2 caused by Rollback in SYSIBM.SYSSEQUENCE

As in PMR 94522,250,631:"Yes, it'd good to ask customer to submit a RFE so that this issue can be evaluated by the DB2 development architects. The current DB2 behavior was designed and implemented before SYSIBM.SYSSEQUENCE exists. Thank you very m...
almost 9 years ago in Db2 for z/OS 3 Not under consideration